Wszystko o budowie rowerów elektrycznych
30lip

Diagnostyka sterownika

 

 

Może się zdarzyć, że rower nie rusza i problem nie leży po stronie silnika, bo diagnoza wykazała jego sprawność.
Należy wtedy przeprowadzić diagnozę sterownika. Proces jest prosty i nie wymaga szczególnej wiedzy oraz umiejętności.

original-8e55d1227fd87b9c672137b138f50d59Potrzebne będą:
1. Sterownik do sprawdzenia
2. Zasilanie sterownika wraz z okablowaniem do podłączenia
3. Miernik

——– Krok 1: Diagnoza tranzystorów ———–

Bardzo często trafia się awaria tranzystorów. Nie trzeba rozkręcać sterownika by je sprawdzić. Można to zrobić z zewnątrz.

original-57f59602e50f0b695c1e22463c636b9boriginal-6ba4c7dc7f209cf7f279f411d7e09fbeSprawdź rezystancję między przewodem MINUS zasilania sterownika, a każdą z faz.
Wartości powinny zawierać się w przedziale 6-12kR i być takie same dla każdej z faz
Następnie sprawdź to samo, ale tym razem miedzy PLUS sterownika, a każdą z faz. Tu także rezystancja powinna zawierać się w przedziale 6-12kR. Z tą jednak różnicą, że rezystancja będzie się powolutku zwiększać jeśli podłączymy miernik na dłużej. To jest normalne, tak ma być. Wszystkie pomiary powinny być bardzo zbliżone.

Jeśli zarejestrowana oporność bardzo odbiega od podanej ,np 0R lub 5megaR – tranzystory podłączone do danego koloru fazy należy wymienić na sprawne.

——— Krok 2: Uruchamianie sterownika ———–

original-f1a0716b5563f8dfce63d76618e4db98original-0f49888353c555962ebdb6868329cf3fJeśli to nie tranzystory są powodem awarii – należy sprawdzić, czy sterownik w ogóle się uruchamia.
Fakt prawidłowego uruchamiania sterownika można określić po tym, że w momencie przełączenia stacyjki pojawia się napięcie 5V dla zasilania manetki oraz czujników halla. Należy więc upewnić się, że sterownik się w ogóle włącza.

Podłączamy sterownik do zasilania i sprawdzamy czy pojawia się 5V

Jak widać – po przełączeniu stacyjki pojawia się 5V, czyli sterownik uruchamia się prawidłowo. Jeśli także silnik jest sprawny (bo przeszedł diagnostykę) – musimy szukać przyczyny dalej (a dokładniej w wszelakich urządzeniach peryferyjnych – opis diagnozy w odpowiednich działach).

Jeśli jednak sterownik nie uruchamia się, nie pojawia się 5V na zasilaniu halli czy manetki – wskazuje to na poważną usterkę samego sterownika.

Pytania, sugestie, pomysły?

komentarzy 38 do wpisu “Diagnostyka sterownika”

  1. Dariusz pisze:

    Witam
    Mój sterownik nie podaje napięcia zasilania na czujniki hall w kole oraz w korbie padołów. Na wyświetlaczu błąd E10

    Czy jest to do naprawienia ?

    Problem był taki że został przerwany przewód czerwony i biały od czujników w kole. Przewody ogarnięte ale sterownik nie daje zasilania.

  2. mateusz pisze:

    witam posiadam dwie hulajnogi elektryczne jedna jest to , bogist c1 do ktorej brakuje wyswietlacza , cala reszta sprawna , druga jest to lamtwheel e-scooter ak-02 tez brak wyswietlacza a tagze stacyjki , czy mozna z nich zrobic jedna o wiekszej mocy , lub czy sa w stanie jedzic bez brakujacych elementow ?

  3. Jakub pisze:

    Witam czy w sabvotonie 72150 da się jakiś wyregulować napięcie bateri ? Mam baterie 92.4v (na mierniku) a sterownik widzi 95.5v co powoduje jego wyłączenie bo 95v to max co można w apce ustawić.nie wiem skąd i pytanie co można z tym zrobić oprócz niedoladowania bateri?

  4. Andrzej pisze:

    Mam Problem z silnikiem Bafang -Przy jeżdzie na wspomaganiu elektrycznym co jakiś czas z reguły gdy jest potrzebne wspomaganie wyłącza sie i jest problem z jazdą -wymieniłem pas/padalec/,wymieniłem sterownik Lubelan Model QS-C 36-11035 uszkodzone były 2 tranzystory na jednej fazie ,uruchomiłem rower i sytuacja się powtarza .Wspomaganie sie wyłacza po chwilowym kręceniu pedałami do tyłu ,lub wylączeniu silnika sytuacja wraca do normalnej pracy i po jakimś nieokreslonym czasie znowu przestaje działać .Czujniki halla wykluczam bo wystlałoby mi sie info na wyswietlaczu error .wyswietlacz nie widzi zadnego błedu .Pomóżcie

  5. Alfred pisze:

    Witam.Mam w sterowniku tranzystory 110N7f6, może masz doświadczenie ,co można zamiast tego włożyć dostępne w kraju?

    • tas pisze:

      w sprawie zamiennika to się nie orientuję ponieważ zazwyczaj mam dużo sztuk z demontażu jakie używam w naprawach :(

  6. Bartosz pisze:

    Witam. Mierząc rezystancje miedzy MINUS a poszczególnymi fazami to mam na 1 fazie wartość 9.94 a na 2 oraz 3 fazie są wartości 9.10 .
    Gdzie moze leżeć problem ?

  7. marek pisze:

    Witam. zrobilo mi sie zwarcie w sterowniku na kostce od wlaczania swiatel, sterownik podobno podawal napiecie bateri 48v na ta kostke po wlaczeniu swiatel z pilota od wyswietlacza. teraz nic sie nie zalacza? padl sterownik?

  8. Krystian pisze:

    Witam proszę pomóż mi naprawić mój sterownik. Nie mogę nigdzie znaleźć zamiennika.

  9. Dariusz pisze:

    Witam. Moze spotkales sie z podobny problemem i pomozesz w diagnozie problemu ze sterownikiem.
    Ale od poczatku.
    Sterownik chinski, niby 2000W 50A, w srodku 18 MOSFETow.
    Podlaczalem wsxystko w warunkach warsztatowycj, na stole, kolo z silnikiem obok na stojaku, wszystko podpiete na zlaczkach WAGO. Podlaczam, uruchamiam samonauke, sprawdzam funkcjie (tempomat, dzialanie manetki, wybor 3 predkosci, itp.)
    Ogolnie wszystko dzialalo ok…
    No i w pewnym momencie szarpnelem przewod manetki i sterownik spadl na podloge z wysokosci biorka (ok 70cm), podczas upadku odczepily sie przewody fazowe od silnika, nic pozatym.

    Podlaczam wszystko spowrotem i lipa.
    Silnik niby sie uruchamia i reaguje na manetke, jednak prasuje jakby na najmniejszej predkosci. Jednak nie ma problemu z ruszeniem z miejsca (tak by sie moglo dziac gdyby brakowalo jednej fazy).
    Nic sie nie dzieje po zwarciu przewodow samonauki.
    Nie dziala tempomat
    Nie dziala zmiana 3 predkosci.

    Mam drugi zapasowy taki sterownik i po jego podpieciu na tych samych zlaczkach wszystko dziala – znacze ze silnik ok.
    Zlaczki pomiezone miernikiem – ok
    Czujniki Halla pomierzone -ok
    Otworzylem sterownik brak widocznych problemow (zimne luty, pekniete elementy, uszkodzenia mechaniczne)
    Tranzystory nie maja zwarcia ani do plusa ani do masy.

    Masz pomysl co moze byc przyczyna takiego zachowania sterownika?

  10. Robert pisze:

    Witam czy możliwe jest wykonanie przez Pana diagnozy i ewentualnej naprawy sterownika firmy AS. BAC 350 ?

  11. Wiesław pisze:

    Przysłano mi sterownik KT60SVPRC60V45As podłączyłem go do pakietu 16s czyli 67V.Sterownik puścił na manetkę i na halla 67V,Na każdej fazie też jest 67V a rezystancja 0.Super bo nowy silnik szlak trafił. I co teraz.

    • tas pisze:

      Wygląda, że pomyliłeś jakieś przewody podczas podłączenia. Pojawienie się takiego napiecia na linii 5V wskazuje na przebicie przetwornicy DCDC sterownikaa. Najczęściej jest to spowodowane pojawieniem się napiecia +BAT na jednym z przewodów sygnałowych. Sterownika raczej już nie uratujesz ale koniecznie sprawdź co zrobiłeś żle aby się to nie powtórzyło

  12. Jakub pisze:

    Witam,
    Mam sterownik sinus KT48 45A. Po przejściu do kroku w którym mierzymy napięcie… na manetce pomiędzy czarnym A czerwonym pokazuje 4.46V, natomiast na halli pomiędzy czarnym A czerwonym nie pokazuje nic. Sterownik tylko raz podłączony do roweru i od nowości nie działał. Czy to oznacza jak nie ma napięcia na halli, ze sterownik do śmieci?

  13. Krzysztof pisze:

    Chinski sterownik 36V/250w kupiony 10 lat temu służył i było dobrze. Starłem zupełnie pas(padelec 5 magnesów)i nie działało „wspomaganie”. Założyłem nowy też 5 magnesów i niestety wspomaganie nie działa. posiłkowałem się manetką z trzema diodami (zielona,żółta,czerwona)ale i ona zaczęło nawalać. Po włączeniu zasilania diody w/w świecą . Manetka jak pisałem raz dział raz nie. Jest jakaś rada na naprawę
    pas(pedalca)i ewentualnie manetki? Tranzystory sprawdziłem-dobre.Silnik sprawny

  14. […] nadal nie będzie działać prawidłowo. Wtedy najpierw przeprowadza się diagnozę silnika oraz diagnozę sterownika czy manetki, a dopiero gdy te nie ujawnia problemów – można pokusić się o otwarcie […]

  15. Łukasz pisze:

    Witam,

    Sterownik Sabvoton ML60 uległ awarii. Wymieniono tranzystory Mosfet na jednej fazie. Po włączeniu miga czerwona dioda 7 razy, a później się zapętla i miga cały czas po 15 razy. Co taki kod oznaczać może ??

  16. Adrian pisze:

    A jak naprawić taką poważną usterkę sterownika ? Bo mój na czujniki halla podaje 0.3v a na manetkę 0.5v ?

  17. Mariusz pisze:

    Witam
    Gdzie znajdę na blogu opisy do sprawdzenia urządzeń peryferyjnych? Przeszukałem całe i nie mogę znaleźć :-(

  18. Piotr pisze:

    Mam dwa takie same sterowniki, jeden z nich ma opornosc 10kohm, a odwrotnie 4kohm i rosnie.
    Drugi 10kohm a odwrotnie 3.46 mohm na kazdym i nie rosnie, znaczy to ze drugi ma uwalone mosfety ?
    Pozdrawiam

  19. Bartłomiej pisze:

    Kupiłem sterownik kt60v45a sinus po podłaczeniu wszystkiego wraz z wyswietlaczem w ogóle nie startował. Sprawdziłem czy w ogóle jest napiecie ze sterownika na wyswietlacz i manetke to na każdym pokazuje 1.8v co może być przyczyną?

    • tas pisze:

      Trzeba odłączyć d roweru i odpalić na stole, wygląda, że zrobiłeś zwarcie gdzieś na kabelkach. Trzeba obadać czy to jeszcze żyje

  20. Przemek pisze:

    Witam, mam problem z moim zestawem 1000W ze sterownikiem KT48
    mianowicie podczas ruszania z silnika wydobywa się buczenie i drgania do prędkości ok 15km/h Słyszałem ze jest to problem sterowników KT. Czy spotkałeś się z takim problemem? Ewentualnie jakiś pomysł na rozwiązanie problemu?

  21. Piotrek pisze:

    Witam,
    zrobiło się ciepło więc wyskoczyłem na rower i po przejechaniu 20m padł mi sterownik – GT 1500:(
    Przepikałem multimetrem kilka rzeczy i okazało się że dwa duże kondensatory były do wymiany (470uF). Nie pomogło (chociaż zaczęła przeskakiwać iskra przy podłączaniu do aku – wcześniej był kompletnie martwy).
    Nie pojawia się napięcie 5v na manetce, sprawdziłem też tranzystory i mam między minusem a fazami po 3,04
    a między plusem a fazami rośnie do ponad 16.

    Moje pytanie – czy jest sens wymieniać tranzystory czy padło więcej rzeczy (skoro nie ma napięcia na manetce) i sterownik się nadaje do wyrzutu ;)

    Pozdrawiam

  22. Tadeusz pisze:

    Sprawdziłem mój sterownik, między minus zasilania a fazy do silnika mam 9 a między plus a fazami mam przerwę .Czy sterownik jest zepsuty , napięcie do monitorka dochodzi. Rower nie pracuje czy to wina sterownika ,sprawdziłem uzwojenia silnika są dobre.

  23. Dariusz pisze:

    okazalo sie ze hamulce byly wlaczone caly czas bo mam takie sensory na magnesy

  24. Dariusz pisze:

    mam nowy kontroller. Nie robilem zadnej adaptacji. Nie uruchamia silnika. Dziala wyswietlacz. Jak sprawdzilem rezystancje to mam 9 na przewodzie minusowym i nie wskazuje nic na plusowym. Czy mozliwe ze taki pomiar nie dziala na wszystkie sterowniki?